Lua version upgrade

Can we upgrade lua version in kong ?

we are using kong 1.2.2 and want to upgrade lua version in it to 5.3

is it supported or we have to upgrade kong version itself

any kong version which has lua version 5.3 in it

Kong uses (and requires) LuaJIT, which is compatible with Lua 5.1, with some extra features from Lua 5.2 and 5.3, like goto and table.move().

See https://repo.or.cz/w/luajit-2.0.git/blob_plain/v2.1:/doc/extensions.html for a list of extensions relative to Lua 5.1

@javier thanks for the update , but my query is on can i upgrade lua version in kong , is it allowed to upgrade ?

short answer, no.

real answer: LuaJIT is not Lua. Both Kong and OpenResty (the underlying scripting platform) require LuaJIT features, like FFI, bit library, and a few others.

Do you require any specific Lua 5.3 feature? As mentioned, LuaJIT does copy a few.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ