Does Kong does not work on newer version of RedHat because of Lua supports?

Hello,

We have a problem with new version of Kong Enterprise Edition on rhell 8 environment. We have a custom plugin (“jwt-plus-auth”) which is working on below old version of Kong and below environments without any issue;

OS Version : Red Hat 7.9
Kong version: 2.0.1
Lua version : 5.1.4

However, custom plugins does not work with the same configuration when we tried to use new Kong version on new RedHat environment.

Env-1

OS Version : Red Hat 8.2
Kong version: 2.3.2.0
Lua version : 5.3.4

Env-2

OS Version : Red Hat 8.2
Kong version: 2.4.1.1-enterprise-edition
Lua version : 5.3.4

RedHat(Rhel 8) supports to install Lua version which is minimum 5.3.x version. As I investigated, Kong does not support Lua version more than 5.1.x (please correct me if I am wrong).
We have a problem here! Kong(2.3.2.0 and 2.4.1.1) seems does not work on newer version of RedHat because of Lua supports!

We use KongA as a UI of Kong and we can see the custom plugins in older version of kong and rhell but cannot see it in newer version of kong and rhell in this UI.

With older kong and rhell:
image

Not shown in newer version of kong kong and rhell:
image

And also we cannot see it in Kong Manager UI.
image

Even we tried to install Lua (5.3.4) binary packages as 5.1.x on rhel 8, it was also not worked. Do you have any plan that kong will support Lua version 5.3.x version?

Please help and explain us if you have any plan about Lua version or kindly support us if you have any other thought about custom plugins changes on newer version Kong and Rhell.
Thanks in advance.

PS: You can also find details what we have configured for custom plugins in all of our environment as below:
  • Environment variables in .bash_profile
$ cat .bash_profile                                                            # .bash_profile                                                                                   01 ~]$                                                                                            # Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

# User specific environment and startup programs

# Kong
export LUA_PATH="./?.lua;/usr/local/share/lua/5.1/?.lua;/usr/local/share/lua/5.1/?/init.lua;/usr/local/share/lua/5.1/?/?.lua;/usr/local/share/lua/5.1/?/?/?.lua;/usr/local/share/lua/5.1/luarocks/?.lua;"
export LUA_CPATH="./?.so;/usr/local/lib/lua/5.1/?.so;/usr/local/lib/lua/5.1/?/?.so"

export KONG_CUSTOM_PLUGINS="jwt-plus-auth"

# custom plugin path
export KONG_LUA_PACKAGE_PATH="/data/jitsi/kong-plugins/?.lua;;"

# disable kong headers - extra config not related to plugins
export KONG_HEADERS="off"

  • /etc/kong/kong.conf
plugins = bundled,jwt-plus-auth
  • Debug lof of kong restart.
    $ kong restart --vv
2021/06/30 09:04:12 [debug] pg_timeout = 5000
2021/06/30 09:04:12 [debug] pg_user = "kongnew"
2021/06/30 09:04:12 [debug] plugins = {"bundled","jwt-plus-auth"}
2021/06/30 09:04:12 [debug] pluginserver_names = {}
2021/06/30 09:04:12 [debug] port_maps = {}

hi,

I have same problem with version 2.4.1.1.

My plugin not shown anymore.

What do we need to do or is there a new configuration for 2.4.1.1 version?

Kong bundles its own openssl, openresty, luajit and otherwise internally in its RPM, so the Red Hat version is unlikely to matter. That isn’t to say the RHEL8 bundle is free of bugs, but more that the Red Hat package versions are unlikely to be a concern.

@tyree731 is right. One caveat though; depending on the Lua path settings, Kong might pick up libraries from the OS, so make sure to clear those paths when running Kong

1 Like

© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ