Can't start Kong after upgrade: jit-uuid exception

Hi guys! It seems I need your help. I’ve spent already four days trying to update my OpenResty+Kong setup to the latest versions. I’ve removed all my config files, tried kong-build-tools repo, but result is the same: I’m getting an error about the jit-uuid library:

2020/02/16 21:58:41 [error] 6#6: init_by_lua error: .../local/openresty/luajit/share/lua/5.1/resty/jit-uuid.lua:106: no request object found
stack traceback:
    [C]: in function 're_find'
    .../local/openresty/luajit/share/lua/5.1/resty/jit-uuid.lua:106: in function 'is_valid'
    .../local/openresty/luajit/share/lua/5.1/resty/jit-uuid.lua:252: in function 'factory_v5'
    ...are/lua/5.1/kong/db/schema/others/declarative_config.lua:390: in main chunk
    [C]: in function 'require'
    ...nresty/luajit/share/lua/5.1/kong/db/declarative/init.lua:1: in main chunk
    [C]: in function 'require'
    ...local/openresty/luajit/share/lua/5.1/kong/clustering.lua:9: in main chunk
    [C]: in function 'require'
    /usr/local/openresty/luajit/share/lua/5.1/kong/init.lua:73: in main chunk
    [C]: in function 'require'
    init_by_lua:2: in main chunk

Also I tried to reinstall this library - nothing helped. PCRE is compiled with --enable-jit and OpenResty with --with-pcre-jit flags.

I will be happy to hear any ideas. Compilations have been done under Alpine 3.10/3.11.

Update: I’ve also tried:

  • Alpine 3.10 / 3.11
  • PCRE 8.42 / 8.43
  • OpenResty 1.15.8.2 / 1.15.8.1
  • Lua 5.1 / 5.2

in different combinations. Nothing helped.

@hutchic or @bungle might be able to help here.

1 Like

The error is strange indeed. It almost feels like it shadows some issue elsewhere.

It think it can be related to the PCRE, but I can’t find the problem. In the same setup OpenResty without Kong can be started without any problems.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ