Use Kong '/config' interface

Hello, everybody!
I have a problem.
*Whenever I use the /config interface to synchronize the kong configuration, I always wait 30 seconds, to get the return value.
Is that normal? Is there any configuration to reduce wait time?

You may want to repost in the general Questions forum or file a GitHub issue. On the Kubernetes end we just generate the configuration and send it to /config; after there it’s all Kong Lua code.

Make sure you’re on the latest version (there have been several DB-less bugs in the past) and check to see if /status output shows any memory segments that are full or close to full. The core team can comment more effectively on this, but I believe it may possibly take longer to load new configuration if the cache segments are nearly full: they can become fragmented and encounter difficulty finding room to allocate new entries, though as best I know this results in errors rather than slowness.

I didn’t find any obvious cause on a brief review of the /config code, and it doesn’t look like it logs anything other than fatal errors, so you’ll probably need assistance from someone who understands it in more detail.

After speaking with the core team, it may be a blocking timeout on anonymous reporting. https://github.com/Kong/kong/commit/a8aebb0e690c44ceacb71f4c91f6c2a8dd30c9ec will address that in 2.1.

For your current version, does setting KONG_ANONYMOUS_REPORTS=off in your Kong container’s environment clear the issue?

https://github.com/Kong/kong/commit/a8aebb0e690c44ceacb71f4c91f6c2a8dd30c9ec

that particular fix is already in 2.0.0 and up. @GQH1993 what Kong version are you running?

  • Thanks for your reply, this configuration has solved my problem.
  • Thanks for your reply!I used version 1.5.1 of kong, and the above friend’s answer helped me solve my proble.