Kong API Gateway Migration from 0.14 to 1.0.3 failing migrations up


#1

I have an existing kong API gateway running on version 0.14 which using psql 9.6. I m trying to migrate it to the newer version which is 1.0.3 following the below link.

I have updated the Openresty version to openresty/1.13.6.2 from 1.13.6.1 which is a prerequisite. I have also performed the openresty patches referring to the documentations successfully. After that I m able to install the newest version i.e, 1.0.3 from the compile source using luarocks. When I check the version of kong it shows 1.0.3 but failing with the migration command.

# sudo kong migrations bootstrap [-c /etc/kong/kong.conf]

Error: cannot bootstrap a non-empty database, upgrade to 0.14 first,and run 'kong migrations up' Run with --v (verbose) or --vv (debug) for more details

Running, # sudo kong migrations up

Error: Migration to 1.0 can only be performed from a 0.14 postgres database, but the current one seems to be older (missing migrations for 'core'). Migrate to 0.14 first, or install 1.0 on a fresh database.

My current kong is running on v0.14 only, then psql db should alo be running on 0.14, according to the error messages, if not than how to upgrade the postgres database to 0.14 so that I can perform the migrations Up???

Kong Restart fails with the below error, # sudo kong start [-c /etc/kong/kong.conf]

Error: /usr/local/share/lua/5.1/kong/cmd/start.lua:37: nginx configuration is invalid (exit code 1): nginx: [emerg] unknown directive "real_ip_header" in /usr/local/kong/nginx-kong.conf:72 nginx: configuration file /usr/local/kong/nginx.conf test failed

When i try to make any changes to the nginx.conf file and try to restart the kong, it just changes back to the originial config (revert changes) and fail with the same error.

I have performed the nginx configuration changes as per the up gradation documentations.

I have also tried installing the new kong version 1.0.3 with the fresh database and also setup konga to it, but when I m trying to restore the my api’s, plugins, upstreams etc… its failing to restore.

How can I migrate my existing kong environment from 0.14 to 1.0.3 pointing to the same psql db so that I do not need to go and create apis manually again. Can somone please help me on this???

Thanks