Error when trying to install last version of kong helm chart (1.7.0) in Kubernetes

Dear all,

I’m a Kong newbie and I’m trying to install Kong in Kubernetes using Helm. I’ve followed the steps in the documentation but an error is displayed in the installation. I tried with the default command and then with the debug command and the same error appears

Here I’m adding the exact command and error that I receive when using the debug flags

helm install --dry-run --debug --namespace junction --tiller-namespace junction kong/kong
[debug] Created tunnel using local port: '46643'

[debug] SERVER: "127.0.0.1:46643"

[debug] Original chart version: ""
[debug] Fetched kong/kong to /home/jpconver/.helm/cache/archive/kong-1.7.0.tgz

[debug] CHART PATH: /home/jpconver/.helm/cache/archive/kong-1.7.0.tgz

Error: parse error in "kong/templates/hpa.yaml": template: kong/templates/hpa.yaml:2: function "ternary" not defined

Also here is my helm version

helm --tiller-namespace junction version
Client: &version.Version{SemVer:"v2.8.1", GitCommit:"6af75a8fd72e2aa18a2b278cfe5c7a1c5feca7f2", GitTreeState:"clean"}
Server: &version.Version{SemVer:"v2.8.1", GitCommit:"6af75a8fd72e2aa18a2b278cfe5c7a1c5feca7f2", GitTreeState:"clean"}

Thanks a lot for any advice or suggestion :smiley:
Best Regards
Juan Pablo

Please upgrade the version of Helm for both client and server.
You are using a very old version of Helm.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ