SSL Problem on Kong Ingress Controller at On Premise?

Cluster information: RKE2

Kubernetes version: v1.28.4+rke2r1
Cloud being used: Baremetal
Installation method: Startup Script
Host OS: Ubuntu 22.04
CNI and version: Canal (rancher/hardened-calico:v3.26.3-build20231109)
CRI and version: containerd://1.7.7-k3s1


Hello everyone, I have an RKE2 Cluster with a topology like this:
A record domain => IP Public => Metallb => Kong Ingress Controller => Service

While I use Cloudflare as DNS and CDN the application runs properly, but when I tried to put the A record without Cloudflare and the SSL termination using Kong Ingress Controller my service does not works properly same as when I use Cloudflare?

But in the browser, I also can access the service. I’ve tried nslookup and curl then my subdomain shows the A record correctly according to the public IP that I have but when I tried to make a CRUD operation to my service and then it did not work properly like the login operation. Anyway my service builted from Nodejs based.

What’s wrong with my service and topology? Thank you for your answer

@tiramisubliss Can you add more context onto which part is not working properly and difference between the working/non-working ones with some examples. It can help others in community understand and help you better.