Custom SSL Certs not working


#1

I’ve installed Kong in k8s using the latest stable helm chart which includes the kong ingress controller. After uploaded my cert and key, enabling TLS to use the secret on the proxy service, I am able to request routes via HTTPS. However, the certificate that shows up is a self-signed Kong certificate and not my cert. It also says it uses HSTS and so I can’t even proceed.

How do I setup Kong with ingress to use my own certs for SSL? Any and all help is greatly appreciated. Thanks in advance.


#2

Hello @dweeb,

We will need more information to help you.
Could you share your k8s specs you’ve used to configure Kong using the Ingress controller?

Have you made sure that the SNI in the request and the one you’ve configured same?


#3

It was a pretty dumb error; I had SSL (secret) in my ingress controller configuration but forgot to enable TLS and the secret for the kong-proxy for the desired SNI. It’s working now.