No default workspace

Hello,
I tried to install Kong while following the tutorial for an installation with Docker but when it’ve been installed, the Kong Management interface (port 8002) doesn’t see any workspace (not even the default).
I made a GET request and the result says that the workspace exists but it looks like the Management interface can’t seen it.

Request :
root@debian:~# root@debian:~# curl -X GET http://localhost:8001/workspaces
{“next”:null,“data”:[{“config”:{“portal_access_request_email”:null,“portal_emails_from”:null,“portal_invite_email”:null,“portal_emails_reply_to”:null,“portal_token_exp”:null,“portal_session_conf”:null,“meta”:null,“portal_auto_approve”:null,“portal_cors_origins”:null,“portal_auth_conf”:null,“portal_developer_meta_fields”:"[{“label”:“Full Name”,“title”:“full_name”,“validator”:{“required”:true,“type”:“string”}}]",“portal_auth”:null,“portal_is_legacy”:null,“portal_reset_email”:null,“portal_approved_email”:null,“portal_reset_success_email”:null,“portal”:false},“name”:“default”,“meta”:{“thumbnail”:null,“color”:null},“id”:“33dd13df-c59c-4062-bf93-3e314627a6a4”,“created_at”:1640102591,“comment”:null}]}

I tried to install it on the Debian machine whithout using Docker too but same result …
Does any one have a solution please ?

Hi Yanis,

Welcome! I would suggest checking the developer tools in the browser for potential errors. I suspect in the console you may see either a CORS or certificate related error like below.

image

In the case of the cert error (self signed), you can open the admin api URL in a new tab to accept the security risk and try to refresh manager.

ref:


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ