Kong Manager via Helm

I’m trying to get Kong Manger working on my development cluster. I’m installing via Helm and my values override file is:
nodeSelector:
kubernetes.io/os: linux
replicaCount: 2
ingressController:
enabled: true
installCRDs: false
env:
plugins: bundled
admin_gui_url: http://manager
admin_listen: 0.0.0.0:8001
admin_gui-listen: 0.0.0.0:8002
lua_package_path: /opt/?.lua;;
prefix: /kong_prefix/
database: “postgres”
pg_host:
valueFrom:
secretKeyRef:
key: host
name: kong-settings
pg_user:
valueFrom:
secretKeyRef:
key: user
name: kong-settings
pg_password:
valueFrom:
secretKeyRef:
key: secret
name: kong-settings
pg_database:
valueFrom:
secretKeyRef:
key: name
name: kong-settings
pg_ssl: “on”
nginx_proxy_proxy_buffer_size: 160k
nginx_proxy_proxy_buffers: 64 160k
proxy:
externalTrafficPolicy: Local
podSecurityPolicy:
readOnlyRootFilesystem: false
admin:
enabled: true
http:
enabled: true
tls:
# Enable HTTPS listen for the admin API
enabled: false
enterprise:
enabled: true
manager:
enabled: true
http:
enabled: true
servicePort: 8002
containerPort: 8002
ingress:
enabled: true
hostname: manager
annotations:
kubernetes.io/ingress.class: “kong”
path: /
tls:
enabled: false

Install complete however I always get:
{
“message”:“An invalid response was received from the upstream server”
}

when try to access Manager via browser.

What am I missing?

Any difference if you remove the various _listen settings from your env? Those and the various Service/Deployment/Ingress ports are normally set up automatically when you set admin.enabled=true and so on. What you have shouldn’t cause issues, but it might.

If not, do you see anything of interest with env.admin_gui_error_log = /dev/stderr and doing kubectl port-forward to port 8002? Bypassing the proxy should hopefully make it a bit clearer what kind of broken response you’re seeing.

Doesn’t make any difference and port forwarding is throwing
Handling connection for 8002
E1220 22:14:06.886453 76728 portforward.go:400] an error occurred forwarding 8002 → 8002: error forwarding port 8002 to pod 32857a9e972e5e4edf64a7019a8395099dbbdd3614f2f6a31eeebdfe61d069a1, uid : failed to execute portforward in network namespace “/var/run/netns/cni-87e43c8d-2122-f812-420b-922587cc36f0”: failed to dial 8002: dial tcp4 127.0.0.1:8002: connect: connection refused
Handling connection for 8002
E1220 22:15:04.755167 76728 portforward.go:340] error creating error stream for port 8002 → 8002: Timeout occurred
Handling connection for 8002

I created a new Kubernetes cluster and performed a fresh install using:
nodeSelector:
kubernetes.io/os: linux
replicaCount: 2
ingressController:
enabled: true
installCRDs: false
env:
plugins: bundled #,oidc
lua_package_path: /opt/?.lua;;
prefix: /kong_prefix/
admin_gui_error_log: /dev/stderr
nginx_proxy_proxy_buffer_size: 160k
nginx_proxy_proxy_buffers: 64 160k
proxy:
externalTrafficPolicy: Local
podSecurityPolicy:
readOnlyRootFilesystem: false
admin:
enabled: true
http:
enabled: true
tls:
enabled: false
enterprise:
enabled: true
portal:
enabled: false
portalapi:
enabled: false

Still doesn’t work nothing in the stderr

What should be running in the Kong Pod I see only ingress-controller and Proxy where does manager run?

Still nothing any other ideas?

That’d indicate it isn’t listening at all. Manager (and everything other the controller) run in the proxy container. I think your issue is that you haven’t changed the image settings, so you’re still using the default OSS image, which doesn’t include Manager.

You’ll want to switch that over to the Enterprise kong-gateway image to use Manager in Enterprise free mode:

(note that we haven’t bumped the version there just yet; 2.7.0.0 is now available).


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ