Kong Manager with Ingress

Hi there,

I am running kong enterprise in k8s. I have a load balancer proxy service and ingress enabled for kong manager. I’m using the official helm chart to deploy kong enterprise and I have the manager service configured like so:

manager:
tls:
enabled: false
type: NodePort
ingress:
enabled: true
path: /manager

This works great - I’m able to hit the manger service with a browser: https://$PROXY_IP/manager
Unfortunately, I get a blank page and inspection of the network tab shows that my manager service is not adding /manager to the path when pulling resources. For example, https://$PROXY_IP/fonts/Roboto-Bold.woff?v=2.137 should be https://$PROXY_IP/manager/fonts/Roboto-Bold.woff?v=2.137. This is one of MANY network calls that are failing. How do I configure the manager service so that it knows to prefix manager to the path?

You need to set KONG_ADMIN_GUI_URL

I did as you suggested, but that did not resolve the issue.

Please share your kong environment variable settings.

I am also facing the same issue but insted of /manager i used /

also attached the network logs

Below are the my configuration details.
values.yml:
env:
database: “postgres”
nginx_worker_processes: “1”
proxy_access_log: /dev/stdout
admin_access_log: /dev/stdout
admin_gui_access_log: /dev/stdout
rbac_auth_header: Kong-Admin-Token
portal_api_access_log: /dev/stdout
proxy_error_log: /dev/stderr
portal_api_error_log: /dev/stderr
prefix: /kong_prefix/
admin_listen: 0.0.0.0:8001
admin_gui_url: http://x.x.x.x:80/
pg_user: kongcp
pg_host: x.x.x.x
pg_port: 5432
pg_database: xxxxxx
pg_password: xxxxxx
password:
valueFrom:
secretKeyRef:
name: kong-enterprise-superuser-password
key: password

manager:
enabled: true
type: NodePort
annotations: {}
http:
enabled: true
servicePort: 8002
containerPort: 8002
parameters: []
tls:
enabled: false
servicePort: 8445
containerPort: 8445
ingress:
enabled: true
hostname:
annotations:
kubernetes.io/ingress.class: “gce”
kubernetes.io/ingress.global-static-ip-name: “kongs-static-ip”
path: /

@shubham.hatwar remove the last “/” from admin_gui_url: http://x.x.x.x:80

Hi But still the problem is not solved.

Getting below error while access the kong-manager from Browser,but when i do curl will get 200 OK Response code.

#kong/ha# curl -v x.x.x.x

  • Rebuilt URL to: x.x.x.x/
  • Trying x.x.x.x …
  • TCP_NODELAY set
  • Connected to x.x.x.x (x.x.x.x) port 80 (#0)

GET / HTTP/1.1
Host: x,.x.x.x
User-Agent: curl/7.52.1
Accept: /

< HTTP/1.1 200 OK
< Server: openresty
< Date: Mon, 29 Jun 2020 07:28:49 GMT
< Content-Type: text/html; charset=UTF-8
< Content-Length: 19392
< Last-Modified: Sat, 30 May 2020 01:04:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0
< X-Frame-Options: sameorigin
< X-XSS-Protection: 1; mode=block
< X-Content-Type-Options: nosniff
< X-Permitted-Cross-Domain-Policies: master-only
< Accept-Ranges: bytes
< Via: 1.1 google

Kindly find the below configuration details and attached error screenshots.

configuration:

values.yml
env:
database: “postgres”
nginx_worker_processes: “1”
proxy_access_log: /dev/stdout
admin_access_log: /dev/stdout
admin_gui_access_log: /dev/stdout
rbac_auth_header: Kong-Admin-Token
portal_api_access_log: /dev/stdout
proxy_error_log: /dev/stderr
portal_api_error_log: /dev/stderr
prefix: /kong_prefix/
admin_listen: 0.0.0.0:8001
admin_gui_url: http://x.x.x.x:80
pg_user: kongcp
pg_host: x.x.x.x
pg_port: 5432
pg_database: xxxxxx
pg_password: xxxxxx
password:
valueFrom:
secretKeyRef:
name: kong-enterprise-superuser-password
key: password

looks like your Kong Manager is exposed on port 8002.
So you probably want to correct that in the admin_gui_url. http://x.x.x.x:8002

Kong property file reference

Also if you using Kong Manager you are enterprise customer please open a support ticket with your support account.Or you might be able to send a email to support@konghq.com
Using that channel will make sure your enterprise SLA are met on any tickets you open and its a private channel as well.

Hi , I am using the the Google Ingress to expose kong outside the kubernetes and in gke ingress port is 80 with ingress ip , so that i have to mention in admin_gui_url. http://1.2.3.4.80
as ingress is listen on port 80 and then in ingress i configure the backend as manager service. And also I change the configuration with port x.x.x.x:8002 but still the issue is same, but curl give me 200 OK response code but when check in UI some 404 error are there

Below Attached code for ingress.yml and value.yml
values.yml
env:
database: “postgres”
nginx_worker_processes: “1”
proxy_access_log: /dev/stdout
admin_access_log: /dev/stdout
admin_gui_access_log: /dev/stdout
rbac_auth_header: Kong-Admin-Token
portal_api_access_log: /dev/stdout
proxy_error_log: /dev/stderr
portal_api_error_log: /dev/stderr
prefix: /kong_prefix/
admin_listen: 0.0.0.0:8001
admin_gui_url: http://x.x.x.x:8002
ing.yml
apiVersion: extensions/v1beta1
kind: Ingress
metadata:
annotations:
kubernetes.io/ingress.class: gce
networking.gke.io/suppress-firewall-xpn-error: “true”
creationTimestamp: “2020-06-30T05:17:56Z”
finalizers:


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ