Kubernetes ingress controller demo for minishift not working

I’m looking into the kong ingress controller demo for minishift. I can’t get it to work? When following the demo instructions this is what happens:

Step 1. Install minishift - OK no problem
Step 2. Create kong-api project - OK no problem
Step 2. Check nodes with: kubectl get nodes - fails since you are not logged in as admin after startup - no worries, just login as admin and it works
Step 3. deploy postgresql - OK no problem
Step.4 Deploy Kong - fails with errors API version in the data (rbac.authorization.k8s.io/v1beta1) does not match the expected API version

I got the minikube demo working after fixing vm-driver, it was using xhyve initially, but, according to kubernetes that driver is deprecated. So I switehc to
using virtualbox. Unfortunately the minishift demo didn’t work even though I tried to use the virtualbox driver? so, something stinks in my attempt to run your demo?

Anyone else that experienced the same?



Hi @krimal,

I’m going to try to reproduce this issue locally and try to come up with a resolution.

Apologies for the delay on our side on this issue.

Hi @krimal,

I just tried creating the resources for ingress controller and it worked fine on my end.
Which version of minishift and Openshift are you using?
Also, are you using the admin privilege for creating RBAC related entities?