Kong Installation on Linux: "version `XCRYPT_2.0' not found"

Hi y’all! I’m running into a show-stopper of a problem with installing Kong. I’ve scowered GitHub issues and other online places, and unfortunately the solutions I found are A) For mac, or B) years old, and not relevant/applicable here in March 2020. Kong has been around for a few years now, so I’m assuming the directions from the installation guide has been fleshed out and assuming that I’m missing something crucial in its installation.

I’m on Pop!_OS 19.10

Both installing from downloaded package and source code provide the same error.
/usr/local/openresty/nginx/sbin/nginx: /lib/x86_64-linux-gnu/libcrypt.so.1: version XCRYPT_2.0’ not found (required by /usr/local/openresty/nginx/sbin/nginx)_Note: For the other places I've installed, such as/usr/bin`, replace the path with_

I’ve installed openresty, disabling nginx (note: Apparently it was never activated) and tried installation in /usr/, /usr/bin/ and /usr/local/

  • My path has /usr/bin and /usr/local, /usr/local/openresty/nginx/sbin/nginx (copying the error message)

My gut tells me its file structure -related. Some questions:

  • What is going on?
  • Should openresty be in /usr/local/?
  • Does Kong have any requirements on where it must be located?

Appreciate any and all help, thank you!

This has been fixed!

It was an issue with my docket network, and I resolved this issue by completely reinstalling Docker. Unsure what specifically was wrong, but hooray!


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ