HTTP/HTTPS ports are disabled from AWS Marketplace? How to enable them?

Just realized that even if I enable the ports through the AWS security group I still can’t access the default HTTP/S ports …

is this by default or a configuration mistake?

$ curl http://localhost
curl: (7) Failed to connect to localhost port 80: Connection refused

works fine with http://localhost:8001 :slight_smile:

so, the “default action” is actually open the ports in the nginx configuration right?

it seems is not straight forward… just looked into

/usr/local/kong/nginx.conf and /usr/local/kong/nginx-kong.conf

and found no command lines to un-comment (or at least I was expecting something like that) :slight_smile:

Can anyone share what’s the best procedure to enable Kong on ports 80/443 by default on a brand new 12.2 AWS Marketplace image ?

I’ve tried to change both nginx.conf and nginx-kong.conf but every time I do kong reload it simply erases the changes back to the default ones :frowning:

for newcomers like me to Kong, check the proxy in your Kong configuration response

for example, curl localhost:8001 will show

    "configuration": {
        "proxy_ip": "",
        "proxy_port": 8000,
        "proxy_listen": "",

        "proxy_ssl_ip": "",
        "proxy_ssl_port": 8443,
        "proxy_listen_ssl": "",

and using the REST Admin API you can change this …

just remember to open the Firewall ports to the server as well.