Enabled parameter not working

I’m sending a POST request to create a plugin with the enabled parameter set to False, but kong ignores it and creates the plugin anyway. This is my payload (Python):

payload = {
                "config" : {
                    "http_endpoint" : http_log_plug_endpoint,
                },
                "enabled" : False
}

I also tryed to send False as a String but it didnt work. Is it an internal error in kong or am i doing something wrong? Thank you.

Kong will create the plugin in this case but the enabled property should be set to false.

1 Like

Thank you. I misunderstood, I thought enable parameter allowed you to check if a request could be applyed or not.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ