SPDY support for kubectl

Hi,
I am trying to forward rancher traffic with kong. The only problem I currently have is that kuectl commands like exec or logs don’t work and fail.
Apparently these commands use the SPDY protocol unlike the frontend that uses websockets.

Is this SPDY protocol supported?

Saw nginx has support for it but I tried adding it to proxy.tls.parameters in the helm chart aka proxy_listen like I did with reuseport but this did fail with:

Error: proxy_listen must be of form: [off] | <ip>: [ssl] [http2] [proxy_protocol] [deferred] [bind] [reuseport] [backlog=%d+], [... next entry ...]
...
proxy:
  enabled: true
  type: "ClusterIP"
  http:
    enabled: true
    hostPort: 80
    parameters:
      - reuseport
  tls:
    enabled: true
    hostPort: 443
    parameters:
      - http2
      - ssl
      - reuseport
...

Any idea how I could get this to work?
Thanks

kong 2.1 helm chart 1.8.0


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ