Problem setting up Kuma


I am new to Kuma and am trying to set up Multi-Zone deployment mode after experimenting with standalone mode. Currently, I have managed to setup the Global Control Plane on an Azure VM and it seems to be working well.

My problem lies in setting up the Zone Control Planes. I have tried setting up on both Docker, WSL and a VirtualBox Ubuntu VM but I am receiving the same error again and again. It should be noted that I am attempting to set this up using Universal mode, as described on Kuma docs, and have tried both versions 1.4.1 and 1.2.3. The error in question is as below:

ERROR kds-zone.kds-mux-client component terminated with an error (“generationID”: 6, “error”: “rpc error; code = Unavailable desc = connection error: desc = “transport: authentication handshake failed: tls: first record does not look like a TLS handshake””}

I have tried googling this problem, but can’t seem to find any similar problems relating to Kuma, and have also tried experimenting in the kuma.conf.yml file but to no avail.

Thank you in advance to anyone who may have any advice on how to solve this.