Installing Kuma Service Mesh and Kong Ingress on Kubernetes

I followed the Exposing Kuma Service Mesh Using Kong API Gateway instructions to install the Kuma Demo Market place application on a microk8s (v1.21.3) Kubernetes cluster running on Red Hat Enterprise Linux release 8.4

I had to change the image from kong-docker-kubernetes-ingress-controller.bintray.io/kong-ingress-controller:0.8.0 to kong/kubernetes-ingress-controller:0.8 to get it going as the bintray images are no longer available.

All installed fine, but when I try to connect to the Marketplace Demo application via the kong-proxy I get the following error:

{"message":"An unexpected error occurred"}

Where could I dig to find what might be causing this issue?

Below is a summary of the running services

kubectl -n kuma-demo get all
NAME                                        READY   STATUS    RESTARTS   AGE
pod/redis-master-55fd8f6f54-q25mb           2/2     Running   0          57m
pod/kuma-demo-backend-v0-56db47c579-ntcpp   2/2     Running   0          57m
pod/kuma-demo-app-6787b4f7f5-dmj4k          2/2     Running   0          57m
pod/postgres-master-645bc44fd-q9q4s         2/2     Running   0          57m
pod/ingress-kong-57bb9b864-nkpsb            3/3     Running   0          38m

NAME                              TYPE           CLUSTER-IP       EXTERNAL-IP   PORT(S)                      AGE
service/postgres                  ClusterIP      10.152.183.52    <none>        5432/TCP                     57m
service/redis                     ClusterIP      10.152.183.168   <none>        6379/TCP                     57m
service/backend                   ClusterIP      10.152.183.93    <none>        3001/TCP                     57m
service/frontend                  ClusterIP      10.152.183.162   <none>        8080/TCP                     57m
service/kong-proxy                LoadBalancer   10.152.183.39    <pending>     80:31143/TCP,443:32410/TCP   38m
service/kong-validation-webhook   ClusterIP      10.152.183.57    <none>        443/TCP                      38m

NAME                                   READY   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/kuma-demo-backend-v1   0/0     0            0           57m
deployment.apps/kuma-demo-backend-v2   0/0     0            0           57m
deployment.apps/redis-master           1/1     1            1           57m
deployment.apps/kuma-demo-backend-v0   1/1     1            1           57m
deployment.apps/kuma-demo-app          1/1     1            1           57m
deployment.apps/postgres-master        1/1     1            1           57m
deployment.apps/ingress-kong           1/1     1            1           38m

NAME                                              DESIRED   CURRENT   READY   AGE
replicaset.apps/kuma-demo-backend-v1-79584cdc57   0         0         0       57m
replicaset.apps/kuma-demo-backend-v2-675df8cbff   0         0         0       57m
replicaset.apps/redis-master-55fd8f6f54           1         1         1       57m
replicaset.apps/kuma-demo-backend-v0-56db47c579   1         1         1       57m
replicaset.apps/kuma-demo-app-6787b4f7f5          1         1         1       57m
replicaset.apps/postgres-master-645bc44fd         1         1         1       57m
replicaset.apps/ingress-kong-57bb9b864            1         1         1       38m
[wayne@rhel-hp kuma]$ curl 10.152.183.39
{"message":"An unexpected error occurred"}

Thanks
Wayne

Hi Wayne,

That blog post is pretty old. What version of kuma you are using?

The latest version (1.2.3) has gateway integrated and you can install Kong ingress controller in gateway mode by running below

kumactl install gateway kong | kubectl apply -f -

Great, thanks. I am using v1.2.3. I will give that command a try and let you know.

Thanks, that worked like a charm. I now have Kuma and Kong Ingress running on my K8S cluster. It is a much simpler install. A small change to the namespace was all I needed and after redeploying my services it worked 100%.

  annotations:
    kuma.io/sidecar-injection: enabled

Thank you very much for the assistance.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ