'No configuration change, skipping sync to Kong' log message

Hello !

We are ingesting logs from ingress-controller to Elasticsearch, and we have this log
no configuration change, skipping sync to Kong which is going to stderr
I guess it’s meaning that the Ingress Controller has detected no changes in K8S resources and has nothing to do

I have 2 questions :

  • Is it possible to remove this message ? If yes, how ?
  • Why is it going to stderr ? It’s not really an error, right ?

Thanks in advance

It is part of logging. It is being logged at the info level so you can use leveled-logging to exclude this from your search.

As I see on this page : https://github.com/Kong/kubernetes-ingress-controller/blob/master/docs/references/cli-arguments.md, you can configure to have more logs but not less

So, I guess the only solution is to filter on Elasticsearch/Kibana.

Still I have a question about an option : --stderrthreshold
In the documentation, it says : logs at or above this threshold go to stderr.
If the log is longer than 2 lines (by default) it goes in stderr, or if the log repeats 2 times it goes to stderr ? How does this parameter works ?

With 0.10.0 version of the controller, logging has been re-written.
The new configuration options are here:

One of the goal is to simplify logging with the new changes.

Thanks ! I’ll try this, but I think I can do what I wanted to do :slight_smile:


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ