Kong worker process is failing with signal 9

We have installed kong in our eks cluster and installing using helm chart. Recently we needed to modify below parameters to enable large file upload possible.
nginx_http_client_max_body_size: “2048m”
nginx_http_client_body_buffer_size: “2048m”

But as soon as do that we started to see error “worker process exited on signal 9”. We assume its because of high memory consumption by kong worker process. Currently our pod memory limit is 1024m and we planning to increase the same to 2048m. But what other parameter should we tweak to get rid of this issue? I mean if we could know how to explicitly increase memory of individual worker_process then it could have been great. FYI currently we are running 2 instances of worker processes.

Hi @indra0007 ,
Were you able to resolve this issue? We are also facing similar issue.