Kong Nginx SSL Handshake

My web service address is https://api.test.com/test/test.svc (the service uses a public certificate)
ping api.test.com > return
curl https://api.test.com > returns without any ssl error

Service and route definitions have been made on Kong

When I test as mykongip:8000/test I get “Eror An invalid response was received from the upstream server.” error.

I see in the nginx logs that it is trying to go to the defined service(https://api.test.com/test/test.svc) over IP and getting SSL_do_handshake error.

2024/01/04 16:56:36 [error] 72562#0: *1245 SSL_do_handshake() failed (SSL: error:0A000152:SSL routines::unsafe legacy renegotiation disabled) while SSL handshaking to upstream, client:, server: kong, request: “GET /test6 HTTP/1.1”, upstream: “”, host: “”, request_id: “2fa6fe0624363e1832d78f361a1f3d16”

I also entered the following parameters in /etc/kong/kong.conf for this error, but no solution. What am I missing?
nginx_proxy_proxy_ssl_server_name = on
nginx_proxy_proxy_ssl_session_reuse = off

Details of the defined service

“request_buffering”: true,
“response_buffering”: true,
“preserve_host”: false,
“https_redirect_status_code”: 426,
“protocols”: [
“methods”: null,
“sources”: null,
“destinations”: null,
“service”: {
“read_timeout”: 60000,
“host”: “api.test.com”,
“enabled”: true,
“path”: “/test/test.svc”,
“id”: “e2688977-0a8c-491a-b469-edc6c537ecac”,
“protocol”: “https”,
“tls_verify”: null,
“tls_verify_depth”: null,
“created_at”: 1703505231,
“write_timeout”: 60000,
“ca_certificates”: null,
“client_certificate”: null,
“port”: 443,
“name”: “test”,
“updated_at”: 1703505231,
“retries”: 5,
“connect_timeout”: 60000,
“tags”: ,
“extras”: {
“createdUser”: null,
“updatedUser”: null,
“id”: 6,
“service_id”: “e2688977-0a8c-491a-b469-edc6c537ecac”,
“kong_node_id”: “1”,
“description”: null,
“tags”: null,
“createdAt”: “2023-12-25T11:53:51.000Z”,
“updatedAt”: “2023-12-25T11:53:51.000Z”
“snis”: null,
“created_at”: 1703505300,
“path_handling”: “v1”,
“tags”: null,
“regex_priority”: 0,
“strip_path”: true,
“name”: “test”,
“updated_at”: 1704446356,
“headers”: null,
“id”: “407b2de9-e0f0-4621-95f8-94fa4ee4e948”,
“hosts”: null,
“paths”: [