Kong Ingress Controller deleting configuration after time


#1

Hi.

I just installed KIG on my GKE Cluster following the readme of https://github.com/Kong/kubernetes-ingress-controller.

After running kubectl apply -f https://bit.ly/kong-ingress all work fine but after some time all my configurations (consumers, plugins, auth_keys, etc) just disappear from the API and I have to start all over again.

I ran a kubectl logs kong-6dddd8b49b-sjdwj -f in search of a DELETE request but I have no luck.

Any tips? is this normal? There’s another way to install Kong Ingress Controller? I tried the Helm Chart but that this is a mess.

Thanks in advance.


#2

@smorales Did you manually configure plugins/consumers/credentials/routes in Kong?

Ingress Controller will remove any manually configured settings in Kong. It will put configuration in Kong that reflects the configuration represented in Kubernetes objects and custom resources like Ingress, KongIngress, KongPlugin, KongConsumer.


#3

That’s what I did. So everything must be an annotation then? If I need a webui (ex. Konga) I must install Kong and not Kong ingress controller?

Cheers


#4

@smorales correct.

So everything must be an annotation then?

To setup plugins, you would need annotations.
For consumers and credentials, you would need to create k8s custom objects and then link them using annotations

If you wish to manage your configuration manually, then using Ingress controller is probably not the right choice and you’re better off using Kong only.