How to turn off DB cache completely

Hello,

We’ve got some interesting issue with kong (1.1.1) and cassandra on k8s.
Due to some race condition (or rather outdated cache) there is a possibility to add a route to the service that has just been deleted

We are checking db_update_frequency but it doesn’t seem to turn off the DB cache completely.
There is the db_cache_ttl parameter, but setting it to 0 turns off the expiration of that cache rather than turning off the cache at all.

The question is:
How to turn off DB cache completely, or at least make it as volatile as possible?

Thanks,

Szymon


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ