How do I deploy Kong with HTTP Load Balancer on EKS

I am trying to setup Kong-ingress on EKS with Application Load Balancer.

Problem is Application Load Balancer setup default health check rule which expects HTTP 200 status to the GET requests on / path. Kong doesn’t provide that out of the box. Does Kong provide any other health check endpoint that I can use?

This is not possible out of the box. You can use a custom server block in Kong to add such a behavior.

1 Like

I tried adding a customer server block as follows-

server {	
    server_name kong_health_check;	
    access_log off;	
    location /health {	
      return 200;	

Still no luck.
Getting request time out.

Have you configued the health-check in the LB to health-check port 9001 and using path /health?

Are the health-check requests timing out or is it the regular requests to proxy port?

Yes I configured the health check port to 9001 in ALB with path /health.
I guess the response was Request time out.
Need to confirm that.

@hbagdi I am also having similar issue. Is there a way around so that I can use GKE https load balancer to hit the proxy service? K8 LB health check is failing . I tried setting up a customer server block with /status, even it is throwing status 404 no luck. Really frustrated