KONG on EKS with ALB

I want to use kong with ALB for stable GRPC connections, so I changed the service type of Kong Proxy from LoadBalancer to NodePort, and created a custom ingress in the same namespace, ‘/’ route is forwarded to service name of kong proxy and nodeport.
but the health checks for the ALB are failing.
Can you help me out with this.

I followed this thread, it works for rest connections (HTTP/HTTPS) but not for GRPC

1 Like

Facing similar issue. Seems like ALB have some issue with GRPC.

Have been trying to do a similar thing, setting the proxy service as a NodePort to use ALB for GRPC.
Facing a similar issue.