Error from Kong when i try to start

Hello everyone,

Recently, I tried to start kong but I have this problem. and I tried to find a solution, but I did not find.
so please if anyone can help me, or have already encountered the same problem.

chmod -R 777 /usr/local/kong :grinning: ?

But also the first error saying “configuration is invalid” makes me think your conf file might be invalid, what did you put in it, does it look like this somewhat?(this is the lua template file used to generate the majority of the conf):

1 Like

How did you install Kong?

I installed it locally, on ubuntu.

I tried the chmod but, it send me back operation not permitted.
And yes, i have the same conf file.

Haven’t you installed as sudo? Kong expects the kong.conf file at /etc/kong/kong.conf by default. Try running chmod as sudo…

1 Like

okay, now it send me back that it was another problems like my plugin is enabled but not installed.
I have already seen this problems, so i think i could find the solution on the discussion forum.
Thank you.

Always glad to help! :slight_smile:

1 Like