[Cassandra error] all hosts tried for query failed. 127.0.0.1: host seems unhealthy, considering it down (connection refused)

Hello Guys,
I try to setup a 2 node kong cluster with 2 connected cassandra databases. I’ve already installed and connected cassandra cluster as you see in below picture

BUT after I tried to run kong migration for the first time I got above error and also I got this error on each of my nodes evert time I try to run migrations

I just change these parameters in kong.conf :
admin_listen = 0.0.0.0:8001, 0.0.0.0:8444 ssl
database = cassandra
cassandra_contact_points = 127.0.0.1
cassandra_port = 9042
**cassandra_keyspace = kong **
cassandra_consistency = ONE
cassandra_timeout = 5000
**cassandra_ssl = off **
cassandra_ssl_verify = off
db_update_propagation = 10

All other parameters have default settings

In cassandra Yaml file both listen address and rpc address are set exactly the same local IPs which means 192.168.153.128 for one node and 192.168.153.132 for the other node
broadcast_rpc_address is not set because when I change the value of this property then cassandra database will down

I really need help about this problem , I’ll really appreciate if someone help me find the solution.

This problem has been solved I just chnaged the cassandra contact point value to the host local ip address and then It works like a charm


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ