Can't start kong in docker

I tried to start kong following the docker guide at but getting

/ line 15: exec: kong: not found

Heres my command log:

❯ docker run -d --name kong-database \
              -p 5432:5432 \
              -e "POSTGRES_USER=kong" \
              -e "POSTGRES_DB=kong" \
Unable to find image 'postgres:9.4' locally
9.4: Pulling from library/postgres
4176fe04cefe: Pull complete
b3acc6da98ed: Pull complete
ef28401016a4: Pull complete
f53d3f24be68: Pull complete
faa03ed01c16: Pull complete
2bd2f4dc2cd2: Pull complete
18fbef78dc91: Pull complete
b7e59e2fc7b6: Pull complete
e1f7a65ca8e6: Pull complete
74bf61bfc5b0: Pull complete
2dce4269ba10: Pull complete
b99df6b6744e: Pull complete
Digest: sha256:6c4d8fd87439a6e7db3c0b3c1edc7beb3ce8df8e30c0589b383a7b1911f21db0
Status: Downloaded newer image for postgres:9.4

~/code/docker-kong master 1m 45s
❯ docker run --rm \
    --link kong-database:kong-database \
    -e "KONG_DATABASE=postgres" \
    -e "KONG_PG_HOST=kong-database" \
    -e "KONG_CASSANDRA_CONTACT_POINTS=kong-database" \
    kong:latest kong migrations up
Unable to find image 'kong:latest' locally
latest: Pulling from library/kong
af4b0a2388c6: Pull complete
a60d79b10ccb: Pull complete
9261ce38e5a9: Pull complete
Digest: sha256:225fea7355e6dc845cfb3f02307237be9aba4d8f852819ce067c96333dde0538
Status: Downloaded newer image for kong:latest
/ line 15: exec: kong: not found

Is there anything else I should do to make this work?


Unfortunately an issue sneaked into the centos image of 0.12.2. We are aware and already submitted a fixed image to the docker hub repository. In the meantime, you can rely on the alpine image or build your own from the docker-kong repository (where the Kong images are maintained).

Sorry for the inconvenience

1 Like

Got it. Thanks!

Get Outlook for iOS

Hi. Is this issue fixed by now? Because I have exactly the same error when following the latest docs ( Install Kong Gateway on Docker - v2.6.x | Kong Docs (