Authentication is not enabled for Kong Manager

Hi everyone,

I am running Kong Manager in Free Mode (enterprise version without license) and when I try to bring up the login page at the /login URL, I got this message:

I have enabled basic-auth as well as RBAC in my Helm chart values.yaml file:

enterprise:
  enabled: true
  # CHANGEME: https://github.com/Kong/charts/blob/main/charts/kong/README.md#kong-enterprise-license
  license_secret: 
  vitals:
    enabled: false
  portal:
    enabled: false
  rbac:
    enabled: true
    admin_gui_auth: basic-auth
    session_conf_secret: kong-session-config
  smtp:
    enabled: false

Is there any other config I need to set in order to enable authentication for Kong Manager?

Also, it is not 100% clear from the documentation if Kong Manager authentication and RBAC is available in Free Mode (enterprise version without license) .

However, I am able to get to the default workspace and see Services, Routes, Consumers etc.

Thanks in advance for any help!

Also, what is strange is that I see in config environments that rbac and enforce_rbac is set to “on” but Admin API returns “off” as values for those environments:

KONG_RBAC:                      on
KONG_ENFORCE_RBAC:              on
KONG_ADMIN_GUI_AUTH:            basic-auth

image