Why is Kong not Installing properly?

I have a Ubuntu server with Kong 1.0.3 running. That one works fine. I intend to upgrade to 1.2 (the latest release at the time of writing, I believe). So I took one for a test on a Ubuntu test server.

I am following the instructions for installation and nothing is happening! There are no error messages nothing. Downloaded the .deb file, ran with sudo dpkg -i and everything is well and smooth.

But when I run the command kong there is no output, the prompt returns, there are no logs created (the prefix being in /usr/local/kong) and I have tried running it with sudo too (just in case the file permissions were any issue).

At the same time, the older release 1.0.3 works well.

I am on Ubuntu 18.04.2
The test machine is actually a small netbook which runs most other things including redis and nginx server, so no hardware issues there.
I have already tried switching on and off the firewall (ufw) - that did not work out.

The main concern is: why is there no output on the command line when I run sudo kong ?