Upstream sent too big header while reading response header from upstream

Hi,

I am getting an issue with status code 502, “upstream sent too big header while reading response headers from upstream….”. Based on my research so far, I have included the following environments in the deployment, ingress-kong.

    - name: KONG_PROXY_PROXY_BUFFER_SIZE
      value: 512k
    - name: KONG_CLIENT_MAX_BODY_SIZE 
      value: "0"
    - name: KONG_LARGE_CLIENT_HEADER_BUFFERS
      value: 16 512k
    - name: KONG_CLIENT_BODY_BUFFER_SIZE
      value: 124m
    - name: KONG_CLIENT_HEADER_BUFFER_SIZE
      value: 512k

However, none of the settings seems to be reflected and working. I am using bitnami/keycloak:20.0.5

Please assist!

Adding an update on this so it’s helpful for others.

I was able to fix this issue by applying a patch with the same values as in the question to the Deployment, proxy-kong

By default, this deployment is in the namespace, kong