Timeout configuration in db-less mode on k8s

Hi there,
I’m trying to change upstream_read_timeout, but in documentation I only see references with the admin api.

I’m using kong on kubernetes, and haven’t got this API enabled.
How can I change this parameter, is there something in ingress or service that I can do ?

thanks

You can use KongIngress CRD.

For example:

apiVersion: configuration.konghq.com/v1
kind: KongIngress
metadata:
  name: read-timeout-demo
proxy:
  read_timeout: 6000

Then associate this to your service.

It works, thanks a lot !


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ