Request termination plugin is being enabled on routes by kong

Hi,
I have enabled multiple authentication for service. Request termination plugin is also enabled on anonymous consumer with the following config and its working fine.
{

  • created_at: 1605975321,

  • id: “c34b51c1-6d12-4e77-8252-33264b248eb1”,

  • tags: null,

  • enabled: true,

  • protocols: [

    • “grpc”,

    • “grpcs”,

    • “http”,

    • “https”],

  • name: “request-termination”,

  • consumer: {

    • id: “7097e7a7-99bc-4551-b925-2f42a892ecf5”},
  • service: null,

  • route: null,

  • config: {

    • status_code: 401,

    • content_type: null,

    • body: null,

    • message: “Authentication Required!”}

}

A strange thing is happening that request termination plugin is being enabled on routes as well with default configurations. Following is the config for routes. I have set the enabled false as well but it value is changed when request is terminated for anonymous
{

  • created_at: 1606454373,

  • id: “1004329c-b5d0-462a-a1af-31d1618b34d3”,

  • tags: [

    • “managed-by-ingress-controller”],
  • enabled: true,

  • protocols: [

    • “http”,

    • “https”],

  • name: “request-termination”,

  • consumer: null,

  • service: null,

  • route: {

    • id: “f375202b-0a5c-44a7-8d79-c2c256c2a844”},
  • config: {

    • status_code: 401,

    • content_type: null,

    • body: null,

    • message: “So long and thanks for all the fish!”}

}
Please let me know if anyone knows what could be the issue. @hbagdi