Remove Server:kong/0.10.3 header but then Server: openresty/ shows up

I want to remove the response header: ‘Server: kong/0.10.3’ when kong sending back the response to the client. According to, I changed to ‘server_token = off’ in kong.conf.ctmpl file. Now the ‘Server:kong/0.10.3’ header was gone, it changed to ‘Server: openresty/’ Is there someway i can also turn off this Server header? Thanks.

@Alice-Ke Hi,

Could you post an example of the request you are sending and response you are seeing? It could help us find out what the culprit component sending the header is.