Passive health Check is not working in Kong after configure the same with a nonresponsive target

We have configured the passive health checks for an upstream URL with a nonresponsive target without active health check, but it is not recognized it. Anybody can help how to configure and verify the same.

Active health checks are working fine

We are using Kong Community 2.0.4. We have deployed this on Azure Kubernetes services and are using Azure Postgresql database as the external database for Kong. Our use case is to have a passive health check configured and enabled for our backend services.
We have configured the same using Active Health checks by specifying the unhealthy timeouts and errors and were able to see it function when service was down. But when we do the same using Passive health checks, we do not see any change in the status of the service and it is always shown as healthy.
From the documentation what we understand is that Active Health checks end up adding to the traffic to the back end services so it was recommended to have passive health checks enabled for the healthy services and have Active health checks enabled for the unhealthy services. But from what we are seeing this is not the behavior that is shown.

  • A passive health check that requires an active request to trigger

Would this mean that the service endpoint should have requests to it for it to be made “unhealthy”? We had tried to do it by making the service unavailable and sending requests to the service routes but we were not able to see this behavior in action.

Active health check and passive health check work together.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ