Ngx.req.http_version() = 1.1

When developing a custom logging plugin, we noticed the ngx.req.http_version() is always 1.1;
Even when we use TLS for the Kong API Gateway - this never goes to 1.2;
Does Kong support HTTP/2 ?
Is the value ngx.req.http_version() reliable ?
Thank you