Nginx: lua atpanic: Lua VM crashed, reason: not enough memory

KONG VERSION:
kong-1.2.1.el7.noarch
Kong: 1.2.1
ngx_lua: 10013
nginx: 1013006
Lua: LuaJIT 2.1.0-beta3

ERROR:
nginx: lua atpanic: Lua VM crashed, reason: not enough memory

QUESTION:
when can I use a memory limit greater than 2 gb ???
2G Memory limit

Enable GC64 mode for x64.

XCFLAGS+= -DLUAJIT_ENABLE_GC64

ps:We didn’t abuse the code, causing memory problems, it is normal need

Please give 1.3.0rc1 a try. It ships with LuaJIT GC64 already enabled.

1 Like

© 2018 Kong Inc.    Terms  •  Privacy  •  FAQ