KongIngress body-size

Hi.

How can I set the body-size in kongingress? And what’s the default?
In nginx.ingress it looks like this: nginx.ingress.kubernetes.io/proxy-body-size: "256m"

Thanks!

You can change this by setting KONG_CLIENT_BODY_BUFFER_SIZE.
Reference: https://docs.konghq.com/1.3.x/configuration/#client_max_body_size

So this is a global parameter and can’t be set per ingress/service?

Correct.
You can set this variable to the max size that you would like to allow globally, and then use request-size-limiting plugin for imposing a max request size per Ingress/Service:


© 2018 Kong Inc.    Terms  •  Privacy  •  FAQ