Kong v 1.4.0 - Getting 504s when adding plugin to route via REST (SOLVED)

504 when adding plugin to route via REST
Wondering if anyone else is hitting the issue too?

This takes forever via curl and also used konga GUI to test the same thing, adding a plugin to an existing route is actually working, however the response is always a timeout, and so I have to add plugin, let it time out, move on to the next one. Kong is using DB and is running in docker. Same issue is not apparent in kong 1.3x

eg

curl -s -X POST https://kong-admin/routes/{route id}/plugins
-H ‘Content-Type: application/json’
-d ‘{
“name”: “acl”,
“service”: {“name”:“web-adapter”},
“route”: {“name”:“webcheck-route”},
“config”: {
“hide_groups_header”: false,
“whitelist”: [
“endpoint_A”
]
},
“enabled”: true,
“run_on”: “first”
}’

Hi @england_2022,

Do you have the same issue we are discussing here?

What DB are you using?

Can you try to turn this off:

e.g. with KONG_ANONYMOUS_REPORTS=off

We are using DB-Less

I’ve been hit by this problem a number of times myself but have not been able to figure out the root cause (yet).

thank you yes,
KONG_ANONYMOUS_REPORTS=off has done the trick for me.

@bungle What is the underlying issue here? Failure to connect to reports server?

After 1 day with these change i confirm we have still 504 errors in some particular routes.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ