Kong Rate Limiting is enabled on load balancer instead real ip

Need help on configuration wrt to real ip for rate limit to work properly. Can you please recommend which config should I tweak in order to achieve it?

Proxy the request

proxy_set_header X-Real-IP $remote_addr;

IP Address

real_ip_header X-Forwarded-For;
set_real_ip_from 0.0.0.0/0;
real_ip_recursive on;

#trusted ip in kong config.
trusted_ips = 0.0.0.0/0,::/0

any other setting i need to consider?

already answered in Kong rate limiting behind load balancer

1 Like

© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ