Kong does not listen nodeport in IPv6

I set dual IP stack in kubernetes
(https://kubernetes.io/docs/tasks/network/validate-dual-stack/)

I check pod dual IP stack
(https://kubernetes.io/docs/tasks/network/validate-dual-stack/)

kubectl get pods kong-7c74b9545d-rtk6v -n cos -o go-template --template=’{{range .status.podIPs}}{{printf “%s \n” .ip}}{{end}}’
10.3.123.118
fc00::3:7b75

IPv4 is working correctly.
Kong did not listen node port after I change ipFamily from IPv4 to IPv6 in kong-proxy service.
I check listen port by “netstat -lntp” command

[env]
kong:1.4.2, kong-ingress-controller:0.6.0
kubernetes on baremetal
IPv6 : kong-proxy
IPv4 : other services

[After IPv6 setting]
kong-proxy NodePort fc01::2b94 80:80/TCP,443:443/TCP 21m

Is there any setting I should add for IPv6 nodeport listening?

You need to tweak KONG_PROXY_LISTEN env var to configure Kong to listen on IPv6 interfaces in addition to IPv4.

Thanks for your fast answer

I tried to change KONG_PROXY_LISTEN
KONG_PROXY_LISTEN=“0.0.0.0:8000,0.0.0.0:8443 ssl,[::]:8000,[::]:8443 ssl”
KONG_PROXY_LISTEN="[::]:8000,[::]:8443 ssl"

but, it did not working, node port was not listening
Is there any other configuration about IPv6?

Your config looks correct. Can you share the generated nginx.conf content to help further debugging?