Kong 2.0 Hybrid mode | DP can't communicate with CP

Hitting with this certificate error. I’m using our existing wildcard certificate and Kong is deployed on Kubernetes/Openshift.

connection to control plane broken: tls handshake failed: certificate host mismatch retrying after 5 seconds, context: ngx.timer

Is there a configuration in Kong to ignore this verification? Any suggestion on how to resolve this?

Thanks

I don’t think this part is (intentionally) not configurable to enforce security.
@datong.sun Can you please confirm?

In our case, the CP& DP are going to be in the same namespace and the communication between the nodes are IPSec enabled. So, may be we can be a bit lenient.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ