Ip-restriction not working through a NLB


#1

For the life of me, I can’t seem to get ip-restriction to work since I’ve got an F5 in front. This is 0.13.1. In the kong.conf, I’ve got:

trusted_ips = 0.0.0.0/0,::0
real_ip_header = X-Forwarded-For
real_ip_recursive = off

I’m 100% sure that the F5 is sending the X-Forwarded-For address to kong. The reason I know that is that I made a quick modification to the access_log settings in nginx,lua as follows:

log_format main '$remote_addr - $remote_user [$time_local] “$request” ’
'$status $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;

$remote_addr is the F5 and $http_x_forwarded_for is the real client’s ip address.

I know this has been asked many times but I just can’t seem to figure it out.


#3

Nevermind. I had a typo in my config. Thanks anyway.


#4

Thanks for the report! Mind marking this resolved?