Installing Kong on EKS with a NLB - wrong values.yaml

Hi,
I am trying to avoid AWS Classic LoadBalancers.
For me this code works, but it creates a classic load balancer

replicaCount: 3
proxy:
  enabled: true
  http:
    enabled: true
    servicePort: 80
    containerPort: 8000
  tls:
    enabled: true
    overrideServiceTargetPort: 8000 
  annotations:
    service.beta.kubernetes.io/aws-load-balancer-ssl-cert: arn:aws:xxxxx
    service.beta.kubernetes.io/aws-load-balancer-backend-protocol: http
    service.beta.kubernetes.io/aws-load-balancer-ssl-ports: "443"
env:
  trusted_ips: "0.0.0.0/0,::/0"

But that creates an AWS Classic loadBalancer

I am trying to create a Network Load Balancer. Following [this](https://yossicohn.medium.com/kong-ingresscontroller-configuration-for-aws-load-balancer-2b226f548afe)

replicaCount: 3
proxy:
  type: LoadBalancer
  enabled: true
  http:
    enabled: false
  annotations:
    service.beta.kubernetes.io/aws-load-balancer-internal: "true"
    service.beta.kubernetes.io/aws-load-balancer-backend-protocol: "https"
    service.beta.kubernetes.io/aws-load-balancer-ssl-ports: "443"
    service.beta.kubernetes.io/aws-load-balancer-ssl-cert: "arn:aws:xxxxx"
    service.beta.kubernetes.io/aws-load-balancer-ssl-negotiation-policy: "ELBSecurityPolicy-TLS13-1-2-2021-06"
    service.beta.kubernetes.io/aws-load-balancer-type: "nlb"

ingressController:
  installCRDs: false

ֿenv:
  headers: "off"
  trusted_ips: 0.0.0.0/0,::0

I am using the helm chart : helm install kong/kong --generate-name -n kong --create-namespace -f kong-values-blog-nlb.yml

Server Version: version.Info{Major:“1”, Minor:“24+”, GitVersion:“v1.24.7-eks-fb459a0”

If you have installed Kong in a EKS with NLB, please can you share the values.yaml?

I’m having the error “Too many redirect”