DB-Less Kong setup on Amazon Linux

I have installed Latest 2.6.x Kong Gateway OSS and db-less mode instructions as per documentation

use the Using decK (YAML) instructions … all good so far but when I run :

deck sync … I am getting this :

deck sync

updating service example_service {
“connect_timeout”: 60000,
“host”: “mockbin.org”,
“id”: “5f2be09e-de92-5059-859b-a01b35cf0d4a”,
“name”: “example_service”,
“port”: 80,
“protocol”: “http”,
“read_timeout”: 60000,

  • “retries”: 5,
    “write_timeout”: 60000
    }

Summary:
Created: 0
Updated: 0
Deleted: 0
Error: 1 errors occurred:
while processing event: {Update} service example_service failed: HTTP status 405 (message: “cannot create or update ‘services’ entities when not using a database”)

Any thoughts - what am I missing for db-less ? why we do even have deck sync if we cannot create or update ‘services’ entities when not using a database" ?

You can’t use deck with Kong deployed in dbless mode.

deck uses Admin API to create Kong entities. Admin API is read only in dbless mode.

Thanks for the quick response. What other options we have for OSS with db-less mode ?

Not too sure if you are using docker or not. As you mentioned OS name, I assume you are installing the RPM package, is that right?

If that’s the case you can specify your declarative config file with this setting.

That’s correct.

So every time I update the kong.yml, Do I have to restart the kong ?

You have two methods of loading the file

  1. Use KONG_DECLARATIVE_CONFIG. When you make a change on the config file, kong reload or restart is needed.
  2. Use /config endpoint

Please check below doc for details


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ