Cookies from Upstream not sent by Kong GW in response


For my use case, I’m working with OpenID Connect and OAuth 2.0, wherein I’m using Keycloak as my Auth Server (Incl. IDP). As Keycloak doesn’t support mTLS 1.2 Mutual authentication mechanism for Client Authentication, I’ll be using Kong Enterprise Plugin (mTLS Plugin) to achieve this. Therefore to achieve the correct flow, I’m placing Keycloak behind Kong and exposing the Auth and Token URLs as “http://localhost:8000/keycloak-auth” and “http://localhost:8000/keycloak-token”.
After this, when I try to get Auth Code and Access Token using Postman as my Client, Keycloak sends me a response that Cookie data is not enabled in the browser, whereas it is enabled by default. When I check the Network for API calls; all responses from Keycloak, that are proxied via Kong don’t contain the Cookies in them. I have tried to use Session Plugin available in the Authentication Plugins tab, but that doesn’t work and the same error is thrown.
Any help and insights on this would be of great help. Thanks!