Can't see correlation-id header in Lambdas

I’m working on my first Kong installation. I’ve tested and verified every bit of functionality (various plugins, services, routes, etc) I need working, but there’s only one thing I can’t get working. I do know for certain that the correlation-id plugin works , because I get the ID passed back downstream to the client (e.g. Postman, curl). However, my Lambdas are not getting the header. Is my expectation that I should be getting the header in my Lambda even correct?

My Lambdas do get any other arbitrary header I set from my client. They also get other headers being set by Kong such as “x-consumer-username”, “x-consumer-custom-id”, etc. My Lambda plugin is using these settings I think could be relevant:

awsgateway_compatible: true
forward_request_headers: true
is-proxy_integration: true

I’ve tried every combination of them on/off but it doesn’t make a difference.
I’ve also tried setting the correlation-id plugin at the global, service, and route levels individually and simultaneously.

Does anyone have any advice for me at all?
Thanks much for reading.


© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ