Activated key-auth plugin from GUI and I locked myself out

Hi,

I activated the key-auth plugin from Kong Manager, and now every request I make returns
{“message”:“No API key found in request”}. I cannot even delete the plugin from the Admin API because I get the same response. Even authenticating as the kong_admin superuser doesn’t work.

Since I created the plugin from the GUI, i cannot see it from kubectl get kongplugins.

I’m using the latest Ingress Controller, with an external postgres instance deployed in the same namespace.

Is there a way to manually disable the plugin? Because removing and reinstalling the deployment didn’t solve the issue.

Thanks in advance for your help!

Using kubectl port-forward to reach the admin API will bypass whatever configuration you have in place on the proxy in front.