ACME/Let's Encrypt on Kong[SOLVED]

Edit: The issue was solved: https://github.com/Kong/kong-plugin-acme/issues/61

Hello, currently I have a Kong API Gateway running through my single node docker swarm with a few API’s behind it, I’m totally able to reach each of the trough each route, but only through HTTP.
I have installed the ACME plugin, although it’s not clear to me how I should configure it in order to trigger the creation of the certificates for each service.

If I run:

curl http://127.0.0.1:8001/acme -d host=mydomain.com -d test_http_challenge_flow=true

It returns:

{"message":"sanity test for host mydomain.com passed"}

But, if I try

curl http://127.0.0.1:8001/acme -d host=mydomain.com

It returns:

{"message":"failed to update certificate: could not create certificate: challenge invalid: http-01: invalid: Invalid response from http:\/\/mydomain\/.well-known\/acme-challenge\/cfbSYzt39OWFm9bObeoL3T7gidAVLRmn1dm7iscz15s [myserverip]: 404"}

This is the container log:

_kong.2.u8d8srbp9lcy@vps-2c1ec9df    |  2020/12/11 15:24:04 [warn] 21#0: *4715 [lua] http-01.lua:54: 
serve_challenge(): no corresponding response found for wSQnWvOVLsxsW2_6RlzxjKjp40in- 
T6SzA8oaY42yCk, client: 10.0.0.2, server: kong, request: "GET /.well-known/acme- 
challenge/wSQnWvOVLsxsW2_6RlzxjKjp40in-T6SzA8oaY42yCk HTTP/1.1", host: "mydomain.com"
kong_kong.2.u8d8srbp9lcy@vps-2c1ec9df    |  10.0.0.2 - - [11/Dec/2020:15:24:04 +0000] "GET /.well- 
known/acme-challenge/wSQnWvOVLsxsW2_6RlzxjKjp40in-T6SzA8oaY42yCk HTTP/1.1" 404 27 "-" 
"Mozilla/5.0 (compatible; Let's Encrypt validation server; +https://www.letsencrypt.org)"

© 2019 Kong Inc.    Terms  •  Privacy  •  FAQ