Response-transformer removes whitespace?

I’m trying to use the request-transformer to set the Vary header. I#m using Kong 1.2, with declarative config, and this is configured as,

  - name: response-transformer
    config:
      append:
        headers: 
        - "Vary:Origin, X-Application-Key, Accept"

However, when I try this out, I get the following Vary header back: ‘Origin,X-Application-Key,Accept’, i.e. the whitespaces have been removed. Is this intended behaviour?

My impression is that the whitespaces are meaningful here, but wasn’t able to find a definitive resource. Even so, it would be interesting to understand why the plugin decided to mutate my configured setting.

Thanks,
-Joris.


© 2018 Kong Inc.    Terms  •  Privacy  •  FAQ